GMB Cover Photo

Hey team,

Curious as to why my GMB cover photo won’t show up as such to my location’s GMB listing?

I’ve updated the GMB cover photo field in Yext but the image isn’t showing up as the Cover photo, it’s more so showing up as another image hidden towards the back of the photo gallery.

Many thanks!

Hi -

Good question. This could be occurring for a few reasons.

  • First, in order for the Cover Photo for GMB to sync from Yext, make sure that the Sync settings are turned on. Data Syncing for certain fields can be adjusted in the Yext platform under Account Settings. For more information on the Sync settings, see the Which Data Sync to Listings module.
  • Second, please review the Photo requirements for GMB and FB here. Google requires a minimum of 250px on the short edge with a file size of at least 10240 bytes.

If you’re still having issues, feel free to respond to this post with any questions or reach out to your Account team.

Best,
Alyssa