Knowledge Graph - Assets Module Assessment

Hi team -

I seem to run into an issue every time I submit my module challenge for Assets in the Knowledge Graph Track.

I’ve closed HH and reopened the challenge again, only to see my saved work in my sandbox environment. I believe I’ve completed all the steps but whenever I submit again, the report card comes back with red Xs.

Let me know if you can help point me in the right direction? I can only attach one photo so here is the screenshot of my photo asset added in the knowledge graph!

Hi @Margaret_DiJulio - Thanks for reaching out!

In order to restart the challenge you’ll need to click on the arrow on the “Open Challenge” button and click on Restart Challenge. Please see the image below. Have you tried both uploading the asset to the platform as well as adding it via URL?


I hope this helps!

Hey Nick!

Thanks so much. Thanks for pointing out the dropdown for ‘Restarting the challenge’ - that was really helpful! However, I’m going through the motions correctly (as far as I can tell) and still getting the red Xs on the report card.

I can’t upload more than one photo to prove how I’ve completed the challenge, but I’ve spot-checked and everything looks good to me. The logo is uploaded as a photo asset, each entity has the photo under business logo, and the template has the logo as well.

Could there be a bug with my submission or am I truly missing all three steps?

Hi @Margaret_DiJulio

A couple things to check:

  1. Have you tried uploading the image as a URL? (Image below)
  2. Have you double checked that you selected all entities and not just the first page?
  3. Have you double checked that the asset is only available for business logo?

Hope this helps!


Thank you! Uploading the image as a URL did the trick; everything else I did the same but maybe that initial step was causing the issue.

Thank you again!

Have you tried uploading the image as a URL? (Image below)

This is a bug and should be explicit in the challenge description. Upload vs URL should have no bearing on the scoring system. I understand bugs like this aren’t that simple, but it’s been over a year and there’s not even a “hint”, “tip”, or “warning” on the page.

I wasted a lot of time (unbeknownst to me) confirming a known bug. Please, we are Hitchhikers, not Trailblazers.