Dm branch does not exist

I’m trying to checkout into the dm branch to work with the directory created in module 5, but it seems this branch does not exist.

Is anyone aware of this problem and can help me, please?

I’m running Into the same issue.
the module is
Pages >Module 5> Unit 4
instructions say
"To see what a complete set of directory templates looks like, there’s a separate branch in your starter repo called dm . To switch branches, run the following command in your terminal:

by running the requested command the output says that there is no such branch, and by listing the branch there is only the master one.

Hi both

Thanks for your question. We are currently updated that track and will release a new version shortly that will not require you to checkout the new branch to make it easier.

In the meantime, you can get the required code by running the following command:

git clone -b dm

Let me know if you have any further questions.

Happy coding!


Thanks for the answer Andrew.

But got this error when I tried to build.

ERROR: Unable to run command "npm run build:local": exit status 127

Hi All,

Wanted to let you know we just published a revised version of the directory manager module here.

I would recommend you start a new repo with yext pages new and then go through the new and improved DM version.

Please let me know how it goes and how I can help!

Thanks and best,

1 Like

Thank you so much Andrew.

It worked as expected!