Final Assessment

tried to finish the consoloe assessment but some of the fields might be different to the ones that I was expecting. Can I get a list of what is supossed to be installed from the food solution? I am only getting “apply food solution with the requested changes” but I don’t really get what those should be (there files mentioned that aren’t there at all, so I am not sure if I used the wrong ones?)

Hi @Frank_Lohrengel ,

I’m afraid I’m not quite sure I understand what you are asking.

When you click button “View Solution” your browser should open the Admin Console in a new tab. It should look like this:

Now click into “default”, and the file structure should begin to be expanded. By clicking into the branches you can finally expand the tree like this:

and find all the files mentioned in the instructions.

Hope this helps
Best, Stefan

Hi Stefan,
yes, in theory that is what I wanted to do. But there were a few items that needed to be checked out, and then were going to be needed, according to the challenge. I did that, and then applied, but the applied solution worked (it didn’t fail it was supossed to), so I think some of the objects have changed somehow, because when i submitted the challed it said the solution had not been applied with the requested objects.
I will give another shot with your recommendations.

Hello Stephan and the rest of the HH team.

I’m experiencing a similarly issue and my final assessment is being marked as incorrect despite completing all the steps listed in the assessment. The module assessment asks us to review the following in the “Diff” section but only the first item is available for me:

  1. An example of adding a new file: km/entity/Menu1.json
  2. An example of updating a file: km/entity-type-extension/job.json

Is there something I’m missing?

Thank you,

Hi Melissa! I am experiencing the same issue, I am stuck at this challenge for a few days now… From the instructions I understand that we just need to apply the food solution and add the description for the Menu Item entity type and then start applying it with authorization etc. I also do not find the second item in the “Diff” section, I wonder if maybe a step in the instructions is missing? I have read through a few topics in here and the challenge seems to have changed over the years.

Anyways also hoping for help here :slight_smile:

Many thanks,

Hi Melissa and Julia,

This rule is failing due to a recent change to the Solution Template. I’m updating the grading rule now and will let you know when you can resubmit your challenge. Apologies for the confusion!

1 Like

Hi again,

The grading rule is updated! I’ve also checked both your accounts and you are passing the rule. You can go ahead and submit the challenge.

1 Like

Thank you very much @Kristy_Huang - everything worked now :blush:

@Kristy_Huang I’m running into a similar error when trying to submit my challenge. Here is the errors I am getting:

Hi Jillian,

Looks like you weren’t able to pass that rule because you didn’t successfully apply the solution template due to the error. That file pages/site-config/FAQ Pages.json is one of the files you should delete before applying the solution template. Once you delete this file, you should be good to apply the solution template and re-submit your challenge.

For more context, the error in your screenshot appears because the feature it is trying to reference is in pages/page-builder-template/FAQ Template.json, which the instructions also say to delete. I’m guessing you already deleted that file which caused it to error out.

Hi Team,

I hope that you’re well.
I’ve been really appreciating the HH program as I’m going through it. Thank you for all your efforts.

I’m also having an issue with this assessment:
After all the editing and deletions that we’re asked to do on the Food Solution, I still can’t complete the assessment, even though I have no errors on the Admin Console - I did “Apply” many times- :
Screenshots below
(I’m not able to add more than one picture in the same comment, I’ll add the second picture in a different comment) :

Thank you for your help.


hi, I’m still getting the same error, and I am not sure what the issue is. I got confirmation the template was applied: