Module 9-Knowledge Graph

I need help regarding Module 9 on Knowledge Graph, on the module assessment it keeps giving me this as a mistake. Even that I do everything as it says and I do Run the connector.

1 Like

Hi Dafina and welcome to the Community!

It looks like the issue is with the configuration of your Connector. You just need to update the URL you have entered in the Connector Source Setting to match what is specified in the instructions.

Once you do that it should pull the data from the help article page and convert those into entities.

Let me know if that works, or if you have any other questions!

Hi thank you for your answer but it is not working, I have the same problem still.

Crawler error Module 9
I too am having the same issue. I followed the directions perfectly AND ran the Connector but it won’t approve as complete in the assessment!?

Hi John,

I took a look at your account, and it seems like you created multiple crawlers with the same name, and the issue seems to be that some Crawlers have the incorrect domain. The domain for the Crawler should be https://help.turtleheadtacos.com.

I’d recommend deleting some of the extra Crawlers you created and updating the Crawler with the ID helparticles to the correct domain. Once you do this you can re-run the Crawler, and then in the next step of configuring the Connector you won’t have multiple crawlers to choose from and can be sure you select the Crawler with the correct configuration.

Let me know if that works or if you run into anything else

Good morning,

I just went back through the whole assessment, deleted ALL the old crawlers but it’s still not letting me complete the assessment!?!

I do appreciate your help. As you can see by looking at my Hitchiker Knowledge Graph track, I have several incompletes. I’m convinced I’m doing the assessment correctly and have researched in the Community but I haven’t been able to get a resolution.

image002.jpg

Hello again,

I checked your account again - the reason why you aren’t passing now is that you had an extra space in the name of the Crawler. Our grading rules look for matches in text fields, so that’s what it was rendering as incorrect.

That said, I removed the space for you and now that should be passing the rules! If you re-submit you should be all set here.

Hooray!!! It worked, I really appreciate it!

I pride myself on the details so I’m sorry about coming across as frustrated, lol?

Wish me luck on the several other Assessments……

Thanks so much!

image002.jpg

Hi There!

I’m running into the issue where I’m being marked for “run your connector to pull in help articles”.

My guess on why it’s not letting me pass is because my activity log for the crawler has failed entities. When I download the report to review the errors it doesn’t make sense because all the page IDs are the same. I also went back to check is there were any leading spaces or misspelling but everything seems to be in order…

@Caroline_Gould would you be able to help or if anyone else has a guess!!

Hi @Amy_Raidel,

A similar issue was brought to our attention for this module recently. It looks like a bug may be affecting the connector so I have escalated it to our techops team for review. I will let you know once I receive an update!

1 Like

amazing! thank you @Micaela_Luders

Hi team! I’m having the same issues - everything looks correct on my end but it’s showing the first 2 steps as incomplete.

Can someone look into this for me? Thank you!

Hey Amy,

Looks like the bug causing some of your entities to fail has been resolved. Once you run the connector again, you should be able to import all the Help Articles successfully. Let me know if you still run into issues with this.

Hey Caitlin,

When you create your crawler, the crawler name should be “Help Articles” (currently you have “Help Article”) since the grading rules are case sensitive.

I would recommend you create a new crawler since the Crawler ID should also be ‘helparticles’ (pulled from the crawler name upon creation) and you won’t be able to edit the ID in the existing crawler’s settings.

Once you have the proper settings for your crawler with ID helparticles, you will then want to make sure you are referencing that crawler within your connector configuration.

1 Like

Thank you!!! I knew it was something so small!

I got the same error, “Run your connector to pull in the help articles.”

I used the exact URL stated in the directions (https://help.turtleheadtacos.com/*").

I found that deleting the %22 and putting in https://help.turtleheadtacos.com/ allowed it work for me.*

@Caroline_Gould - maybe this %22 should be removed in the prompt below:

“* URLs: Select Specific URLs or URL Patterns and enter “https://help.turtleheadtacos.com/*" – this will pull all of the help articles but not the homepage”

Hi,

I am in running my connector to pull in help articles but have followed the steps, could you please let me know what I’m doing wrong?

Kind Regards

Hi @Riccardo_Ronchi -

After taking a look at your account, it seems that you need to update the following within your connector configuration:

  • Crawler settings: the URL pattern should be written as https://help.turtleheadtacos.com/* but right now you have https://help.turtleheadtacos.com

Once you do that, take a look at the Specify Selectors and see if data is returning for all selectors. If not, I recommend looking at step 11 of the challenge instructions and checking that the selectors are added properly.

Let me know if this helps!

Hi Micaela,

Thanks so much for helping out, it has worked.

Riccardo