Suppress Use of Linked Entity Name Field in Search?

I have a Entity Relationship between two Entities and the linked Entity has several fields that I want to include in Search. The “name” field is not one of them, though. My understanding is that it is automatically included in Search. Is there a way to suppress that? If I, for example, include something like the following in the JSON, specifying nothing for the linked name field, will that work?

    "c_linkedDesign.c_vout6Nominal": {
      "phraseMatch": true,
      "textSearch": true
    "": {},             <----------THIS LINE
    "": {
      "facet": true,
      "phraseMatch": true,
      "textSearch": true

Hi @Chick_Webb! I’m not certain there’s a way to do this today, but interested in the use case. Could you explain a little more about what you’re looking to achieve and why name should be suppressed in Search?


Hi @Chick_Webb , the only fields that will be used for search are the fields that you explicitly indicate in the config should be searched with a specific algorithm. We don’t automatically search on the name fields of related entities, unless you enable that field with text match or phrase match or otherwise.


I’m trying to ensure we don’t get bad search results. The linked entity name is irrelevant and could, if searched, potentially raise the relevance of the entity it’s linked to, causing it to appear as a result. I don’t want that. The only fields in the linked entity that I care about are the metadata fields, anyway.

Good to know. I swear I read somewhere that there were a couple of fields of linked entities (name included) that were automatically enabled for search. Must’ve misinterpreted that. I assume leaving that line in the JSON isn’t going to hurt anything, yes?

Got it, thanks for clarifying! I’m wondering if this screenshot is where the confusion might have come from? When creating a vertical, name will automatically be included in searchable fields but is not required to keep (you can click on “Add/Update Fields” and uncheck any fields you don’t want to make searchable, including the name field).

Thanks for the response. I wasn’t adding a Vertical, though, I was adding searchable fields to an existing one from a newly-linked Entity. I believe that the Entity and name field are the only ones that display in the “Add/Update Field” dialog, and that you have to add any additional fields from the linked entity directly in the JSON. I can’t recall if that name field was automatically checked when I added the linked Entity or not, but it’s good to know that you can uncheck it (or just leave the configuration blank in the JSON). Mine configuration looks like this now: